<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html  xmlns:fb="http://ogp.me/ns/fb#" xmlns:og="http://ogp.me/ns#" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="shortcut icon" href="http://amandala.com.bz/news/wp-content/uploads/2012/08/favicon.ico" type="image/x-icon" />
<title>Mayflower Street/Ghost Town and GSU rumble | Amandala Newspaper</title>
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/style.css" />
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/skins/featured_long_style.css" />
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/featured_long.css" />
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/tabs.css" />
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/firstnavigation.css" />
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/secondnavigation.css" />
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/skins/default.css" />
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/skins/slider/skyali/skin.css" />
<link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/prettyPhoto.css" />

<!-- SEO Ultimate (http://www.seodesignsolutions.com/wordpress-seo/) -->
	<link rel="canonical" href="http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/" />
	<meta name="keywords" content="gsu,police,mayflower,flowers’,said." />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Mayflower Street/Ghost Town and GSU rumble" />
	<meta property="og:url" content="http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/" />
	<meta property="og:image" content="http://amandala.com.bz/news/wp-content/uploads/2018/03/Kendis-Flowers.gif" />
	<meta property="article:published_time" content="2018-03-30" />
	<meta property="article:modified_time" content="2018-03-28" />
	<meta property="article:author" content="http://amandala.com.bz/news/author/deshawn/" />
	<meta property="article:section" content="Headline" />
	<meta property="og:site_name" content="Amandala Newspaper" />
	<meta name="twitter:card" content="summary" />
<!-- /SEO Ultimate -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Amandala Newspaper &raquo; Feed" href="http://amandala.com.bz/news/feed/" />
<link rel="alternate" type="application/rss+xml" title="Amandala Newspaper &raquo; Comments Feed" href="http://amandala.com.bz/news/comments/feed/" />
<!-- This site is powered by Shareaholic - https://shareaholic.com -->
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    (function() {
      var shr = document.createElement('script');
      shr.setAttribute('data-cfasync', 'false');
      shr.src = '//dsms0mj1bbhn4.cloudfront.net/assets/pub/shareaholic.js';
      shr.type = 'text/javascript'; shr.async = 'true';
      shr.onload = shr.onreadystatechange = function() {
        var rs = this.readyState;
        if (rs && rs != 'complete' && rs != 'loaded') return;
        var site_id = 'eb023680a7c6b009f9b5012a0ce35e47';
        var page_config = {"apps":{"share_buttons":{"get_share_counts":  function(url, services, cb) {
    Shareaholic.Utils.ajax({
      cache: true,
      cache_ttl: '1 minute',
      url: 'http://amandala.com.bz/news/wp-admin/admin-ajax.php',
      data: { action: 'shareaholic_share_counts_api', url: url, services: services },
      success: function(res) {
        if(res && res.data) {
          cb(res.data, true);
        }
      }
    })
  }}}};
        try { Shareaholic.init(site_id, page_config); } catch (e) {}
      };
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(shr, s);
    })();
  //]]>
</script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='Amandala Newspaper' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/' />
<meta name='shareaholic:keywords' content='headline' />
<meta name='shareaholic:article_published_time' content='2018-03-30T06:04:50+00:00' />
<meta name='shareaholic:article_modified_time' content='2018-03-30T06:05:58+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Deshawn Swasey' />
<meta name='shareaholic:site_id' content='eb023680a7c6b009f9b5012a0ce35e47' />
<meta name='shareaholic:wp_version' content='7.5.0.4' />
<meta name='shareaholic:image' content='http://amandala.com.bz/news/wp-content/uploads/2018/03/Kendis-Flowers.gif' />
<!-- Shareaholic Content Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/amandala.com.bz\/news\/wp-includes\/js\/wp-emoji-release.min.js?ver=e8b0be65958c3af06b639aff2a75fea2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://amandala.com.bz/news/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='linkssc-style-css'  href='http://amandala.com.bz/news/wp-content/plugins/links-shortcode/links-shortcode.css?ver=e8b0be65958c3af06b639aff2a75fea2' type='text/css' media='all' />
<link rel='stylesheet' id='recent-facebook-posts-css-css'  href='http://amandala.com.bz/news/wp-content/plugins/recent-facebook-posts/assets/css/default.css?ver=1.8.5' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel-css-css'  href='http://amandala.com.bz/news/wp-content/plugins/wp-carousel-free/inc/owl-carousel/owl.carousel.css?ver=e8b0be65958c3af06b639aff2a75fea2' type='text/css' media='all' />
<link rel='stylesheet' id='owl-transitions-css-css'  href='http://amandala.com.bz/news/wp-content/plugins/wp-carousel-free/inc/owl-carousel/owl.transitions.css?ver=e8b0be65958c3af06b639aff2a75fea2' type='text/css' media='all' />
<link rel='stylesheet' id='owl-theme-css-css'  href='http://amandala.com.bz/news/wp-content/plugins/wp-carousel-free/inc/owl-carousel/owl.theme.css?ver=e8b0be65958c3af06b639aff2a75fea2' type='text/css' media='all' />
<link rel='stylesheet' id='wcf-fontello-css-css'  href='http://amandala.com.bz/news/wp-content/plugins/wp-carousel-free/inc/fontello/css/fontello.css?ver=e8b0be65958c3af06b639aff2a75fea2' type='text/css' media='all' />
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/js/jquery.min.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/js/jquery-ui.min.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/js/tabs.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/js/superfish.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/js/hoverIntent.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/js/custom.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/js/jquery.jcarousel.min.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/js/jquery.prettyPhoto.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<link rel='https://api.w.org/' href='http://amandala.com.bz/news/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://amandala.com.bz/news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://amandala.com.bz/news/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Foreigners outnumber Belizeans; American Jadine Riley &#8211; 29th Women Cross Country Champion' href='http://amandala.com.bz/news/foreigners-outnumber-belizeans-american-jadine-riley-29th-women-cross-country-champion/' />
<link rel='next' title='Jury acquits Hilberto Perez, 50, of manslaughter' href='http://amandala.com.bz/news/jury-acquits-hilberto-perez-50-manslaughter/' />

<link rel='shortlink' href='http://amandala.com.bz/news/?p=304292' />
<link rel="alternate" type="application/json+oembed" href="http://amandala.com.bz/news/wp-json/oembed/1.0/embed?url=http%3A%2F%2Famandala.com.bz%2Fnews%2Fmayflower-streetghost-town-gsu-rumble%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://amandala.com.bz/news/wp-json/oembed/1.0/embed?url=http%3A%2F%2Famandala.com.bz%2Fnews%2Fmayflower-streetghost-town-gsu-rumble%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.17 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px; }
	.g-2 { margin:1px; }
	.g-3 { margin:1px; }
	.g-4 { margin:1px; }
	.g-5 { margin:1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<meta property='og:type' content='article' />
<meta property='og:title' content='Mayflower Street/Ghost Town and GSU rumble' />
<meta property='og:url' content='http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/' />
<meta property='og:description' content='Angry residents and police clash over allegations of police involvement in Kendis Flowers’ death BELIZE CITY, Mon. Mar. 26, 2018-- The weekend of Saturday, March 17, was the bloodiest weekend so far for the year. In Belize City alone, five persons died from gunshot injuries, and a sixth murder was reported in the Orange Walk District. Notable among the murders in Belize City was that of the Ghost Town gang leader Kendis Flowers, 26, who was laid to rest on Sunday. Reports are that gunshots were heard during and after the funeral ceremonies. When Flowers’ family members and friends and affiliates returned to Mayflower Street for a repast, all hell broke loose when the police’s Gang Suppression Unit (GSU) showed up and attempted to make an arrest. The presence of the GSU triggered outrage from Flowers’ family members, mostly the female members of the family, who were in a yard at #5 Mayflower Street. That is because from the time of Flowers’ murder,  […]' />
<meta property='og:site_name' content='Amandala Newspaper' />
<meta property='fb:app_id' content='199286080135440' />
<meta property='og:locale' content='en_US' />
<meta property='og:image' content='http://amandala.com.bz/news/wp-content/uploads/2018/03/Kendis-Flowers.gif' />
<link rel='image_src' href='http://amandala.com.bz/news/wp-content/uploads/2018/03/Kendis-Flowers.gif' />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//amandala.com.bz/news/?wordfence_lh=1&hid=10973309CA5B7BE5B097F40CC96AA233');
</script><link rel="stylesheet" media="screen" href="http://amandala.com.bz/news/wp-content/plugins/wp-marquee/css/marquee.css" /><!--[if IE 7]>

        <link rel="stylesheet" type="text/css" href="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/scripts/css/ie7.css">

<![endif]-->
</head>
<body>
<div id="container">
<div id="headernavigation">
<div class="navigation">
 
					<ul id="menu-first-menu" class="firstnav-menu sf-menu"><li id="menu-item-295794" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295794"><a href="http://amandala.com.bz/news/advertising/">Advertising</a></li>
<li id="menu-item-295795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295795"><a href="http://amandala.com.bz/news/advertising/ad-specs/">Ad Specs</a></li>
<li id="menu-item-295797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295797"><a href="http://amandala.com.bz/news/advertising/friday-advertising-rates/">Friday Advertising Rates</a></li>
<li id="menu-item-295799" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295799"><a href="http://amandala.com.bz/news/advertising/tuesday-advertising-rates/">Tuesday Advertising Rates</a></li>
<li id="menu-item-295798" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295798"><a href="http://amandala.com.bz/news/advertising/online-amandala/">Online Amandala</a></li>
<li id="menu-item-295801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295801"><a href="http://amandala.com.bz/news/contact/">Contact Us</a></li>
</ul>
                    
<div class="icon_holder"><a href="http://amandala.com.bz/news?feed=rss2"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/rss.png" alt="Subscribe to our Rss" class="shareimg"  /></a></div><!-- #icon holder closer -->
</div><!-- #navigation closer -->

</div><!-- #headernavigation closer -->

<div id="content">

<div id="white_space">

<div id="content_holder">

<div id="header">

<a href="http://amandala.com.bz/news"><img src="http://www.amandala.com.bz/news/wp-content/themes/amandala/assets/images/amandala-logo.png"  border="0" alt="Amandala Newspaper" class="logo"  /></a>
<div class="ad">
<a href="http://amandala.com.bz/news/advertising/"><img src="http://amandala.com.bz/news/wp-content/uploads/2013/09/Advertise-with-us.jpg"></a>


</div>

<div class="ad "><a href="http://amandala.com.bz/news/advertising/"><img src="http://amandala.com.bz/news/wp-content/uploads/2013/09/Advertise-with-us.jpg" alt="468 X 60"  /></a></div><!-- #ad 468x60 closer -->
</div><!-- #header closer -->

<div id="categories">

    
					<ul id="menu-main-menu" class="secondnav-menu sf-js-enabled sf-menu"><li id="menu-item-297355" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-297355"><a href="http://amandala.com.bz/news/">Home</a></li>
<li id="menu-item-261832" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-261832"><a href="http://amandala.com.bz/news/category/headline/">Headline</a></li>
<li id="menu-item-276110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-276110"><a href="http://amandala.com.bz/news/category/highlights/">Highlights</a></li>
<li id="menu-item-276108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-276108"><a href="http://amandala.com.bz/news/category/general/">General</a></li>
<li id="menu-item-261830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261830"><a href="http://amandala.com.bz/news/category/features/">Features</a></li>
<li id="menu-item-261838" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261838"><a href="http://amandala.com.bz/news/category/sports/">Sports</a></li>
<li id="menu-item-261834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261834"><a href="http://amandala.com.bz/news/category/letters/">Letters</a></li>
<li id="menu-item-261829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-261829"><a href="http://amandala.com.bz/news/category/editorial/">Editorial</a>
<ul class="sub-menu">
	<li id="menu-item-297358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297358"><a href="http://amandala.com.bz/news/category/editorial/">English</a></li>
	<li id="menu-item-297356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297356"><a href="http://amandala.com.bz/news/category/spanish-editorial/">Spanish</a></li>
</ul>
</li>
<li id="menu-item-261836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-261836"><a href="http://amandala.com.bz/news/category/publisher/">Publisher</a>
<ul class="sub-menu">
	<li id="menu-item-297359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297359"><a href="http://amandala.com.bz/news/category/publisher/">English</a></li>
	<li id="menu-item-297357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297357"><a href="http://amandala.com.bz/news/category/publisher-spanish/">Spanish</a></li>
</ul>
</li>
<li id="menu-item-297360" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-297360"><a href="http://amandala.com.bz/news/classified_ads/">Classifieds</a></li>
<li id="menu-item-297361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297361"><a href="http://amandala.com.bz/news/feed/">RSS feed</a></li>
</ul>
                    


</div><!-- #categories closer -->

<div class="cat_line"></div>





<div id="middle">

<div id="left" style="width:605px;">

<div class="single">

<div class="active"><h1><a href="http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/">Mayflower Street/Ghost Town and GSU rumble</a></h1></div>

<div class="date">

<div class="left">

<span class="date">	
	<a href="http://amandala.com.bz/news/category/headline/" rel="category tag">Headline</a>	<span class="time"> 
		— 30 March 2018	</span>
	<span class="time"> 
				— by Rowland A. Parks	</span>
</span>

</div><!-- #left -->

</div><!-- #date -->

<div class="content">
<div class="thumb ">
<a href="http://amandala.com.bz/news/wp-content/uploads/2018/03/Kendis-Flowers.gif" rel="prettyPhoto" title="Mayflower Street/Ghost Town and GSU rumble"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=http://amandala.com.bz/news/wp-content/uploads/2018/03/Kendis-Flowers.gif&amp;w=150&amp;zc=0&amp;q=100"  alt="Mayflower Street/Ghost Town and GSU rumble" class="imgf" /></a></div><!-- #thumb --><h4 style="text-align: center;">Angry residents and police clash over allegations of police involvement in Kendis Flowers’ death</h4>
<p style="text-align: justify;">BELIZE CITY, Mon. Mar. 26, 2018&#8211; The weekend of Saturday, March 17, was the bloodiest weekend so far for the year. In Belize City alone, five persons died from gunshot injuries, and a sixth murder was reported in the Orange Walk District. Notable among the murders in Belize City was that of the Ghost Town gang leader Kendis Flowers, 26, who was laid to rest on Sunday.</p>
<p style="text-align: justify;">Reports are that gunshots were heard during and after the funeral ceremonies. When Flowers’ family members and friends and affiliates returned to Mayflower Street for a repast, all hell broke loose when the police’s Gang Suppression Unit (GSU) showed up and attempted to make an arrest.</p>
<p style="text-align: justify;">The presence of the GSU triggered outrage from Flowers’ family members, mostly the female members of the family, who were in a yard at #5 Mayflower Street. That is because from the time of Flowers’ murder, there have been innuendos and rumors circulating in the community that the GSU had a hand in the execution of the 26-year-old.</p>
<p style="text-align: justify;">Police had issued a statement denying that any police officer was involved in the fatal early- morning shooting, which had occurred in a rival gang’s territory, in the vicinity of Mahogany Street and Sittee Street, which is in the Back-a-Town gang area.</p>
<p style="text-align: justify;">When Flowers’ body was found, there was a gun on his chest, and his right hand appeared to have been clutching the gun. His relatives and friends believe, however, that the gun was planted on him. More than one source has confirmed to Amandala that Flowers was left-handed.</p>
<p style="text-align: justify;">Then crucial surveillance video footage that police had collected from a business in the area where the murder occurred, which they had promised that they would show to Flowers’ family, has still not been shown to them.</p>
<p style="text-align: justify;">Amandala’s investigation, however, has revealed that indeed, police reviewed the surveillance footage from a Chinese shop in the area where the shooting occurred. The location from which Flowers’ body was retrieved, however, would seem to indicate that it would not have been possible for the surveillance camera to have captured the incident, unless he was shot immediately in front of the shop, which is not the case.</p>
<p style="text-align: justify;">Amandala also spoke with a resident in the area of the shooting. That person said that when the first shots were fired, he took precaution and went down on the floor in his room. Then he heard the voice of a man asking the shooter, “why are you shooting me?”</p>
<p style="text-align: justify;">This was followed by another shot, Amandala was told.</p>
<p style="text-align: justify;">A resident of the area told us that if Flowers had a gun, as police said, then he would not have asked his assailant that question – he would rather have been shooting back at him.</p>
<p style="text-align: justify;">On Sunday evening, as the GSU walked into the yard in the Mayflower area where the grievers had assembled, more than one person began videoing what was taking place between Flowers’ family and the officers. More than one video was live-streamed on Facebook and immediately, the videos went viral. At present, more than 30,000 persons have watched the videos.</p>
<p style="text-align: justify;">Within a short period of time, the power of social media was evident, as thousands of people viewed the videos and their disturbing contents, which included an audio recording of women shouting expletives at the police, and the police firing a number of live rounds and rubber bullets, two of which ricocheted and hit two persons.</p>
<p style="text-align: justify;">In one of the videos, a woman was seen lying on the ground, obviously in some kind of distress. At first, the impression was that she was hit by one of the bullets fired by the police, but it was found that the woman had been pepper-sprayed.</p>
<p style="text-align: justify;"> This morning, Amandala went to #5 Mayflower Street to speak with Flowers’ family.</p>
<p style="text-align: justify;"> Sandra Uter, 63, Kendis Flowers’ grandmother, explained that they had just returned home from the cemetery and were in the process of having a repast for those who had come to the yard after the funeral.</p>
<p style="text-align: justify;">“Everyone was gathered around after the funeral, some were in the street and some were inside the yard. About six to seven GSU walked into the yard. They didn’t say anything to anyone. They just went and grabbed one of my grandsons. He resisted, and asked, ‘Weh unnu di ker me fa?’ “ she said.</p>
<p style="text-align: justify;">She further related, “People started to cuss, and one of the other officers told the GSU officer who was holding her grandson, to stand down. But he and the boy were struggling together, and he never obeyed the order to stand down.</p>
<p style="text-align: justify;">“So with that, people started to come in the yard, because they heard us cussing out the GSU. We di tell dem that we noh want dem inna the yard, because some of dem responsible fu my grandson’s death.</p>
<p style="text-align: justify;">“Everybody from off the street start come inna di yard. The GSU started to crank up their guns. This young lady right ya [Uter pointed to a woman sitting on a chair], tell dem to get out of the yard, and they pepper-sprayed her.</p>
<p style="text-align: justify;">Our dog made grab after his [the officer’s] foot and he turned around and shot the dog, but the dog noh dead.</p>
<p style="text-align: justify;">“While the commotion still di go on with the young man, everybody got annoyed and tried to chase dem out the yard. They started to fire shots in the air. A total of twelve 9mm shell casings and some spent shotgun cartridges were picked by the children from around the yard.”</p>
<p style="text-align: justify;">Uter explained that some of the bullets fired by the GSU were rubber bullets.</p>
<p style="text-align: justify;">“One of the rubber bullets ricocheted and caught one of my granddaughters on her hand. Several persons were hit,” Uter said.</p>
<p style="text-align: justify;">Amandala asked Uter if it is true that shots were being fired, so the police had to come.</p>
<p style="text-align: justify;">“It’s true; shots were being fired. But we had nothing to do with that. The shots were being fired from behind here, from the direction of the alley,” Uter explained.</p>
<p style="text-align: justify;">“The Deputy Commissioner of Police, Chester Williams, made a post on his Facebook page this morning, saying that he was the one who sent the police. How do you respond to that?” we asked Uter.</p>
<p style="text-align: justify;">“Well, he did the wrong thing! Because we confided in Chester; he already knows that we suspect the GSU was involved in my grandson’s death. So before he sent them, he should have come to us, or send the regular police, not the GSU,” Uter said.</p>
<p style="text-align: justify;">She explained that Deputy Commissioner Williams had promised to show the family the surveillance video, but what they showed them was a few seconds and the only thing that was on the few seconds of surveillance video was a white vehicle.</p>
<p style="text-align: justify;">“There was no body on the ground,” Uter said.</p>
<p style="text-align: justify;">Kendis Flowers lived under constant threat of death from rival gangs and from the police, his mother, Sharmaine Stewart, told Amandala.</p>
<p style="text-align: justify;">Flowers first came to the public’s attention at the age of 16, in May 2008. He was one of the eleven persons who were injured when a hand grenade attack was carried out at the corner of Mayflower and Vernon Streets. One person died as a result of that attack. This was the first section of the city in which a hand grenade attack had taken place.</p>
<p style="text-align: justify;">As he grew older, Flowers would later become involved in a number of incidents for which he was charged by police. As recently as last June, Flowers was charged for shooting at police.</p>
<p style="text-align: justify;">We asked Stewart if she was aware that the reason the GSU was sent to the area was that the “21-gun salute” was being carried out for her son.</p>
<p style="text-align: justify;">Stewart said that when the funeral was going on, she was in a vehicle. “I did hear some shots. But I did not know that it was a ‘21-gun salute’ for Kendis,” Stewart said.</p>
<p style="text-align: justify;">Stewart said that after the funeral, when they were back at the yard, the GSU came and she approached them, saying: “Unu kill my son. Weh unu want? We noh waahn unu ya because unu done kill my pikni.” “And I wahn tell dem to dem face dat da dem kill my pikni, until dem show me that video fu prove dat da noh dem,” she added.</p>
<p style="text-align: justify;">Stewart spoke of a certain member of the GSU who she alleged had been threatening to kill her son. “Every time he si my son, he tell am dat he gwine kill am. He and his GSU crew always come here, take my son and put gun to his head, and tell am dehn wahn kill am. So that is the reason why I believe that they are involved in my son’s death,” said Stewart.</p>
<p style="text-align: justify;">At the heart of the family’s suspicion about the police’s involvement in Kendis’ death is a surveillance video from a Chinese shop that police allegedly obtained. The belief of the family is that the video captured the shooting.</p>
<p style="text-align: justify;">According to Stewart, all of her son’s jewelry, as well as his money, were found on him. “If it was a rival gang they would have taken his jewelry,” she said.</p>
<p style="text-align: justify;">We asked Stewart what happened to the young man whom the GSU went to the yard to arrest.</p>
<p style="text-align: justify;">Stewart said that they took the young man and released him without charging him for any offense.</p>
<p style="text-align: justify;">“They let him go from last night without any charge,” Stewart said. “When the GSU come in my yard, the first person they ask for is Kendis. ‘Weh Kendis deh,’ they always asked,” she said.</p>
<p style="text-align: justify;">“Sometimes I seh, weh happen, he do something? They said no, they just want to know weh he deh,” Stewart said.</p>
<p style="text-align: justify;">At the weekly police press briefing this morning, Monday, ASP Alejandro Cowo, the Crimes Investigation Branch commander, told the media that there was no information on the Mayflower Street incident which occurred yesterday evening at the Flowers’ family yard. ASP Cowo informed the media that a press briefing would be held later during the week.</p>
<p style="text-align: justify;">While ASP Cowo had no update on the Mayflower Street incident for the media, his senior officer, Deputy Commissioner of Police, Chester Williams, posted on his Facebook page as follows: “I’ve noticed a number of comments regarding the incident in the Mayflower area yesterday, and I’m very happy to see that for the most part, the comments were favorable to the police. For those who do not know what actually happened, let me enlighten you. Since the death of Kendis Flowers we have exercised great restraint where his colleagues are concerned, for the simple reason that we want them to mourn in peace.”</p>
<p style="text-align: justify;">Deputy Commissioner Williams went on to describe what transpired during the church service: “We heard several shots being fired from within the area, people from within were repeatedly calling the police because they felt scared. Despite this, we chose not to go in at that time, because the church service was still ongoing and we did not want to have any confrontation, so we allowed the funeral to continue,” he said.</p>
<p style="text-align: justify;">He further explained, “After church service, the funeral attendees proceeded to the cemetery to lay their loved one to rest, after which they returned to the Mayflower area. Upon reaching the Mayflower area, shots were again heard ringing out of the area, and again the residents from that area were frantically calling for the police.</p>
<p style="text-align: justify;">“Responding to the calls of those citizens who felt threatened by what was taking place, I decided to put together a team of police officers and BDF and deploy them into the area to arrest the situation.”</p>
<p style="text-align: justify;">Deputy Williams added, “As you can all see from the videos, upon the law enforcement team entering they were immediately attacked by a mob comprising of mostly females, and despite that, the officers exercised great restraint.</p>
<p style="text-align: justify;">“I will say this, I do believe in a softer side of policing, and to engage the public, but one must understand that community policing does not mean to tolerate lawlessness to prevail. The police cannot and will not be intimidated by no group who want to create havoc in our communities; it is our duty to deal with those who commit themselves.</p>
<p style="text-align: justify;">“We will continue to foster a better relationship with the public with a view to make our communities safer for all. We cannot win the war against crime if we allow lawlessness to prevail, or to allow any group to believe that they can do as they please and get away.”</p>
<p style="text-align: justify;">Late today, the Ministry of National Security issued the following press release on the Mayflower Street incident:<br />
“The Ministry of National Security has reviewed the facts surrounding the confrontation, which occurred on Sunday, March 25, between security personnel and residents of the Mayflower Street area.</p>
<p style="text-align: justify;">“The Ministry is satisfied that there was justifiable cause for security personnel to enter the area, as there were multiple reports of gunfire in the vicinity, which created a state of fear and panic among residents in the area.</p>
<p style="text-align: justify;">“Furthermore, the Ministry is satisfied that the authorities exercised great restraint in the face of verbal and physical attacks on them. The incident resulted in the injury of two police officers.”</p>
<div class='shareaholic-canvas' data-app-id='7641146' data-app='share_buttons' data-title='Mayflower Street/Ghost Town and GSU rumble' data-link='http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/' data-summary=''></div></div><!-- #content -->
<div id="video_holder" style="display:none;"></div>

<div class="post_heading"><h2 class="left_heading ">Related Articles</h2></div><!-- #post_heading -->
<div class="related_articles ">
<a href="http://amandala.com.bz/news/barrow-jacks-fuel-prices-easter/" title="Barrow jacks up fuel prices for Easter"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/Fuel-price.gif&amp;w=95&amp;h=74&amp;zc=1&amp;q=100" alt="Barrow jacks up fuel prices for Easter" /></a>
<a href="http://amandala.com.bz/news/mario-guerrero-64-murdered-sunset-park/" title="Mario Guerrero, 64, murdered in Sunset Park"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/Guerrero.gif&amp;w=95&amp;h=74&amp;zc=1&amp;q=100" alt="Mario Guerrero, 64, murdered in Sunset Park" /></a>
<a href="http://amandala.com.bz/news/belize-aquaculture-limited-lays-100-employees-citing-disease-high-cost-operating/" title="Belize Aquaculture Limited lays off 100 employees,   citing disease and high      cost of operating"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/BAL.gif&amp;w=95&amp;h=74&amp;zc=1&amp;q=100" alt="Belize Aquaculture Limited lays off 100 employees,   citing disease and high      cost of operating" /></a>
<a href="http://amandala.com.bz/news/pup-trashes-barrows-1-83-billion-budget/" title="PUP trashes Barrow’s $1.83 billion budget"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/cordel-and-johnny.gif&amp;w=95&amp;h=74&amp;zc=1&amp;q=100" alt="PUP trashes Barrow’s $1.83 billion budget" class="last" /></a>
</div><!-- #related_articles -->

<div class="post_heading"><h2 class="left_heading hideobject">Share</h2></div><!-- #post_heading -->

<div class="share hideobject"> 
  <a href="http://www.facebook.com/sharer.php?u=http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/&t=Mayflower Street/Ghost Town and GSU rumble"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/facebook-icon.png" class="shareimg" /></a>
  <a href="http://twitter.com/home/?status=Mayflower Street/Ghost Town and GSU rumble&nbsp;-&nbsp;http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/twitter-icon.png" class="shareimg" /></a>
  <a href="http://www.reddit.com/submit?url=http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/&amp;title=Mayflower Street/Ghost Town and GSU rumble"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/reddit-icon.png" class="shareimg" /></a>
  <a href="http://digg.com/submit?url=http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/&amp;title=Mayflower Street/Ghost Town and GSU rumble&amp;thumbnails=1"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/digg-icon.png" class="shareimg" /></a>
  <a href="http://www.google.com/reader/link?title=Mayflower Street/Ghost Town and GSU rumble&amp;url=http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/google-icon.png" class="shareimg" /></a>
  <a href="http://www.stumbleupon.com/submit?url=http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/&amp;title=Mayflower Street/Ghost Town and GSU rumble"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/stumbleupon-icon.png" class="shareimg" /></a>
  <a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/&amp;title=Mayflower Street/Ghost Town and GSU rumble&amp;source="><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/linkedin-icon.png" class="shareimg" /></a>
  <a href="http://del.icio.us/post?url=http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/&amp;title=Mayflower Street/Ghost Town and GSU rumble"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/delicious-icon.png" class="last shareimg" /></a>
</div><!-- #share -->

<div class="post_heading"><h2 class="left_heading hideobject">About Author</h2></div><!-- #post_heading -->

<div class="author hideobject">

<div class="icon">


<div class="title">Deshawn Swasey</div><!-- #title -->

</div><!-- #icon -->

<div class="authorcontent">

<p></p>

</div><!-- #content -->

</div><!-- #author -->


</div><!-- #single -->


<div class="post_heading"><h2 class="left_heading">(0) Readers Comments </h2></div><!-- #post_heading -->
  
<div id="comments">


	<p class="nocomments">Comments are closed.</p>


 </div><!-- Comment Holder -->



</div><!-- #left closer -->
<div id="right">
<div id="search-5" class="widget-container widget_search rightwidget"><h3 class="widget-title"><span class="title">Search Amandala News</span></h3><form method="get" id="searchform" action="http://amandala.com.bz/news">
<input type="text" class="search"  name="s" id="s" value="" />
<input type="submit" class="searchb" value="" />
</form></div><div id="text-52" class="widget-container widget_text rightwidget">			<div class="textwidget"><a href="http://amandala.com.bz/news/category/publisher/"><img class="alignnone wp-image-295660 size-medium" src="http://amandala.com.bz/news/wp-content/uploads/2017/02/From-the-Publisher-Evan-X.png" alt="" width="300" height="186" /></a></div>
		</div><div id="text-51" class="widget-container widget_text rightwidget">			<div class="textwidget"><a href="http://amandala.com.bz/news/category/editorial/"><img class="aligncenter wp-image-296023 size-medium" src="http://amandala.com.bz/news/wp-content/uploads/2017/02/Amandala-Editorial-English-2017.png" alt="" width="300" height="186" /></a></div>
		</div><div id="text-50" class="widget-container widget_text rightwidget">			<div class="textwidget"><a href="http://amandala.com.bz/news/classified_ads/"><img class="aligncenter size-full wp-image-278925" src="http://amandala.com.bz/news/wp-content/uploads/2017/11/classifieds-buttn.png" alt="" width="300" height="75" /></a></div>
		</div><!-- //**********************************
   TABS POPULAR, RECENT, COMMENTS, TAGS
//*************************************** -->
<div id="londontabs" class="widget ">
<div id="tabsheader" class="tabsheader">
<ul class="tabnav">
<li><a href="#populartab">Popular</a></li>
<li><a href="#recenttab">Recent</a></li>
<li><a href="#commentstab">Comments</a></li>
<li class="tagslast"><a href="#tagtab" class="tagslast">Tags</a></li>
</ul>
</div><!-- #header -->
<div id="populartab" class="tabdiv"><!-- #popular -->
<div class="tab_inside">
<a href="http://amandala.com.bz/news/jury-acquits-hilberto-perez-50-manslaughter/"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/Hilberto-Perez.gif&amp;w=53&amp;h=41&amp;zc=1&amp;q=100" alt="Jury acquits Hilberto Perez, 50, of manslaughter" /></a>
<div class="content"><h1><a href="http://amandala.com.bz/news/jury-acquits-hilberto-perez-50-manslaughter/">Jury acquits Hilberto Perez, 50, of manslaughter</a></h1> <br  /> <span class="date">March 30,  2018   </span></div><!-- #content closer -->
</div><!-- #tab_inside -->
<div class="tab_inside">
<div class="content"><h1><a href="http://amandala.com.bz/news/anna-tells-police-to-get-their-act-in-place/">Anna tells police to ?get their act in place?</a></h1> <br  /> <span class="date">November 06,  2000   </span></div><!-- #content closer -->
</div><!-- #tab_inside -->
<div class="tab_inside">
<div class="content"><h1><a href="http://amandala.com.bz/news/from-the-publisher-251161/">FROM THE PUBLISHER</a></h1> <br  /> <span class="date">November 08,  2000   </span></div><!-- #content closer -->
</div><!-- #tab_inside -->
<div class="tab_inside">
<div class="content"><h1><a href="http://amandala.com.bz/news/70-at-compre-spells-trouble-for-rural-kids/">70 at Compre spells trouble for rural kids</a></h1> <br  /> <span class="date">November 08,  2000   </span></div><!-- #content closer -->
</div><!-- #tab_inside -->
<div class="tab_inside">
<div class="content"><h1><a href="http://amandala.com.bz/news/p-m-accuses-udp-of-extortion-on-ccj-bill/">P.M. accuses UDP of `extortion` on CCJ bill!!</a></h1> <br  /> <span class="date">July 17,  2004   </span></div><!-- #content closer -->
</div><!-- #tab_inside -->
</div><!--#popular -->


<div id="recenttab" class="tabdiv"><!-- #recent tab -->

<div class="tab_inside"><a href="http://amandala.com.bz/news/jury-acquits-hilberto-perez-50-manslaughter/"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/Hilberto-Perez.gif&amp;w=53&amp;h=41&amp;zc=1&amp;q=100" alt="Jury acquits Hilberto Perez, 50, of manslaughter" /></a>
<div class="content"><h1><a href="http://amandala.com.bz/news/jury-acquits-hilberto-perez-50-manslaughter/">Jury acquits Hilberto Perez, 50, of manslaughter</a></h1> <br  /> <span class="date">March 30,  2018</span></div><!-- #content closer -->
</div><!-- #tab_inside -->
<div class="tab_inside"><a href="http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/Kendis-Flowers.gif&amp;w=53&amp;h=41&amp;zc=1&amp;q=100" alt="Mayflower Street/Ghost Town and GSU rumble" /></a>
<div class="content"><h1><a href="http://amandala.com.bz/news/mayflower-streetghost-town-gsu-rumble/">Mayflower Street/Ghost Town and GSU rumble</a></h1> <br  /> <span class="date">March 30,  2018</span></div><!-- #content closer -->
</div><!-- #tab_inside -->
<div class="tab_inside"><a href="http://amandala.com.bz/news/foreigners-outnumber-belizeans-american-jadine-riley-29th-women-cross-country-champion/"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/Female-top-5-champs.gif&amp;w=53&amp;h=41&amp;zc=1&amp;q=100" alt="Foreigners outnumber Belizeans; American Jadine Riley &#8211; 29th Women Cross Country Champion" /></a>
<div class="content"><h1><a href="http://amandala.com.bz/news/foreigners-outnumber-belizeans-american-jadine-riley-29th-women-cross-country-champion/">Foreigners outnumber Belizeans; American Jadine Riley &#8211; 29th Women Cross Country Champion</a></h1> <br  /> <span class="date">March 30,  2018</span></div><!-- #content closer -->
</div><!-- #tab_inside -->
<div class="tab_inside"><a href="http://amandala.com.bz/news/eva-middleton-activist-manager-bapda-dies/"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2018/03/Eva-Middleton.gif&amp;w=53&amp;h=41&amp;zc=1&amp;q=100" alt="Eva Middleton, activist and manager for BAPDA, dies" /></a>
<div class="content"><h1><a href="http://amandala.com.bz/news/eva-middleton-activist-manager-bapda-dies/">Eva Middleton, activist and manager for BAPDA, dies</a></h1> <br  /> <span class="date">March 30,  2018</span></div><!-- #content closer -->
</div><!-- #tab_inside -->
<div class="tab_inside"><a href="http://amandala.com.bz/news/bernards-tough-job/"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/thumb.php?src=/wp-content/uploads/2017/07/colin-hyde.jpg&amp;w=53&amp;h=41&amp;zc=1&amp;q=100" alt="The other Bernard’s tough job" /></a>
<div class="content"><h1><a href="http://amandala.com.bz/news/bernards-tough-job/">The other Bernard’s tough job</a></h1> <br  /> <span class="date">March 30,  2018</span></div><!-- #content closer -->
</div><!-- #tab_inside -->

</div><!--#recent tab -->


<div id="commentstab" class="tabdiv"><!-- #commentstab -->


</div><!-- #commentstab -->


<div id="tagtab" class="tabdiv"><!-- #tagtab -->

<a href='http://amandala.com.bz/news/tag/3feb2016/' class='tag-link-706 tag-link-position-1' title='14 topics' style='font-size: 9.93305439331pt;'>3feb2016</a>
<a href='http://amandala.com.bz/news/tag/6feb2016/' class='tag-link-708 tag-link-position-2' title='17 topics' style='font-size: 10.4016736402pt;'>6feb2016</a>
<a href='http://amandala.com.bz/news/tag/9feb2016/' class='tag-link-709 tag-link-position-3' title='14 topics' style='font-size: 9.93305439331pt;'>9feb2016</a>
<a href='http://amandala.com.bz/news/tag/13feb2016/' class='tag-link-710 tag-link-position-4' title='19 topics' style='font-size: 10.6359832636pt;'>13feb2016</a>
<a href='http://amandala.com.bz/news/tag/20jan2016/' class='tag-link-697 tag-link-position-5' title='18 topics' style='font-size: 10.5188284519pt;'>20jan2016</a>
<a href='http://amandala.com.bz/news/tag/23jan2016/' class='tag-link-698 tag-link-position-6' title='18 topics' style='font-size: 10.5188284519pt;'>23jan2016</a>
<a href='http://amandala.com.bz/news/tag/27jan2016/' class='tag-link-699 tag-link-position-7' title='14 topics' style='font-size: 9.93305439331pt;'>27jan2016</a>
<a href='http://amandala.com.bz/news/tag/30jan2016/' class='tag-link-705 tag-link-position-8' title='24 topics' style='font-size: 11.2217573222pt;'>30jan2016</a>
<a href='http://amandala.com.bz/news/tag/adele-ramos/' class='tag-link-100 tag-link-position-9' title='798 topics' style='font-size: 20.0083682008pt;'>adele ramos</a>
<a href='http://amandala.com.bz/news/tag/amandala/' class='tag-link-40 tag-link-position-10' title='1,417 topics' style='font-size: 21.4728033473pt;'>amandala</a>
<a href='http://amandala.com.bz/news/tag/audrey-matura-shepherd/' class='tag-link-140 tag-link-position-11' title='11 topics' style='font-size: 9.34728033473pt;'>Audrey Matura-Shepherd</a>
<a href='http://amandala.com.bz/news/tag/banking/' class='tag-link-49 tag-link-position-12' title='9 topics' style='font-size: 8.87866108787pt;'>banking</a>
<a href='http://amandala.com.bz/news/tag/basketball/' class='tag-link-63 tag-link-position-13' title='7 topics' style='font-size: 8.29288702929pt;'>basketball</a>
<a href='http://amandala.com.bz/news/tag/belize/' class='tag-link-37 tag-link-position-14' title='1,731 topics' style='font-size: 22pt;'>belize</a>
<a href='http://amandala.com.bz/news/tag/belize-city/' class='tag-link-236 tag-link-position-15' title='17 topics' style='font-size: 10.4016736402pt;'>belize city</a>
<a href='http://amandala.com.bz/news/tag/cricket/' class='tag-link-152 tag-link-position-16' title='8 topics' style='font-size: 8.58577405858pt;'>cricket</a>
<a href='http://amandala.com.bz/news/tag/crime-2/' class='tag-link-59 tag-link-position-17' title='108 topics' style='font-size: 14.9707112971pt;'>crime</a>
<a href='http://amandala.com.bz/news/tag/cycling/' class='tag-link-265 tag-link-position-18' title='9 topics' style='font-size: 8.87866108787pt;'>cycling</a>
<a href='http://amandala.com.bz/news/tag/economy-2/' class='tag-link-51 tag-link-position-19' title='9 topics' style='font-size: 8.87866108787pt;'>economy</a>
<a href='http://amandala.com.bz/news/tag/editorial-2/' class='tag-link-86 tag-link-position-20' title='47 topics' style='font-size: 12.8619246862pt;'>editorial</a>
<a href='http://amandala.com.bz/news/tag/evan-x-hyde/' class='tag-link-70 tag-link-position-21' title='25 topics' style='font-size: 11.280334728pt;'>evan x hyde</a>
<a href='http://amandala.com.bz/news/tag/finance/' class='tag-link-718 tag-link-position-22' title='6 topics' style='font-size: 8pt;'>finance</a>
<a href='http://amandala.com.bz/news/tag/football/' class='tag-link-121 tag-link-position-23' title='39 topics' style='font-size: 12.3933054393pt;'>football</a>
<a href='http://amandala.com.bz/news/tag/from-the-publisher/' class='tag-link-138 tag-link-position-24' title='10 topics' style='font-size: 9.1129707113pt;'>from the publisher</a>
<a href='http://amandala.com.bz/news/tag/garifuna/' class='tag-link-364 tag-link-position-25' title='14 topics' style='font-size: 9.93305439331pt;'>garifuna</a>
<a href='http://amandala.com.bz/news/tag/guatemala/' class='tag-link-250 tag-link-position-26' title='13 topics' style='font-size: 9.75732217573pt;'>guatemala</a>
<a href='http://amandala.com.bz/news/tag/health-2/' class='tag-link-91 tag-link-position-27' title='16 topics' style='font-size: 10.2259414226pt;'>health</a>
<a href='http://amandala.com.bz/news/tag/letter/' class='tag-link-591 tag-link-position-28' title='9 topics' style='font-size: 8.87866108787pt;'>letter</a>
<a href='http://amandala.com.bz/news/tag/letter-to-the-editor/' class='tag-link-137 tag-link-position-29' title='62 topics' style='font-size: 13.5648535565pt;'>letter to the editor</a>
<a href='http://amandala.com.bz/news/tag/lgbt/' class='tag-link-77 tag-link-position-30' title='7 topics' style='font-size: 8.29288702929pt;'>lgbt</a>
<a href='http://amandala.com.bz/news/tag/maya/' class='tag-link-175 tag-link-position-31' title='9 topics' style='font-size: 8.87866108787pt;'>maya</a>
<a href='http://amandala.com.bz/news/tag/murder/' class='tag-link-73 tag-link-position-32' title='44 topics' style='font-size: 12.6861924686pt;'>murder</a>
<a href='http://amandala.com.bz/news/tag/national-security/' class='tag-link-477 tag-link-position-33' title='8 topics' style='font-size: 8.58577405858pt;'>national security</a>
<a href='http://amandala.com.bz/news/tag/news/' class='tag-link-120 tag-link-position-34' title='1,376 topics' style='font-size: 21.4142259414pt;'>news</a>
<a href='http://amandala.com.bz/news/tag/opinion/' class='tag-link-71 tag-link-position-35' title='8 topics' style='font-size: 8.58577405858pt;'>opinion</a>
<a href='http://amandala.com.bz/news/tag/police/' class='tag-link-31 tag-link-position-36' title='9 topics' style='font-size: 8.87866108787pt;'>police</a>
<a href='http://amandala.com.bz/news/tag/politics-2/' class='tag-link-377 tag-link-position-37' title='11 topics' style='font-size: 9.34728033473pt;'>politics</a>
<a href='http://amandala.com.bz/news/tag/publisher-2/' class='tag-link-69 tag-link-position-38' title='18 topics' style='font-size: 10.5188284519pt;'>publisher</a>
<a href='http://amandala.com.bz/news/tag/shooting/' class='tag-link-67 tag-link-position-39' title='6 topics' style='font-size: 8pt;'>shooting</a>
<a href='http://amandala.com.bz/news/tag/sports-2/' class='tag-link-62 tag-link-position-40' title='120 topics' style='font-size: 15.2050209205pt;'>sports</a>
<a href='http://amandala.com.bz/news/tag/sugar/' class='tag-link-332 tag-link-position-41' title='9 topics' style='font-size: 8.87866108787pt;'>sugar</a>
<a href='http://amandala.com.bz/news/tag/sugar-industry/' class='tag-link-124 tag-link-position-42' title='13 topics' style='font-size: 9.75732217573pt;'>sugar industry</a>
<a href='http://amandala.com.bz/news/tag/tourism/' class='tag-link-720 tag-link-position-43' title='9 topics' style='font-size: 8.87866108787pt;'>Tourism</a>
<a href='http://amandala.com.bz/news/tag/traffic-accident/' class='tag-link-150 tag-link-position-44' title='12 topics' style='font-size: 9.5230125523pt;'>traffic accident</a>
<a href='http://amandala.com.bz/news/tag/volleyball/' class='tag-link-74 tag-link-position-45' title='6 topics' style='font-size: 8pt;'>volleyball</a></div><!--#tagtab closer-->

</div><!--#tagtab -->

<!-- //**********************************
   TABS END
//*************************************** -->

<div id="text-53" class="widget-container widget_text rightwidget">			<div class="textwidget"><a href="http://www.amandala.com.bz/evan_x_hyde/"><img class="aligncenter wp-image-278908 size-full" src="http://amandala.com.bz/news/wp-content/uploads/2014/08/Boss-Book-300.jpg" alt="" width="300" height="250" /></a></div>
		</div><div id="text-54" class="widget-container widget_text rightwidget">			<div class="textwidget"></div>
		</div><div id="text-2" class="widget-container widget_text rightwidget">			<div class="textwidget"><a href="http://amandala.com.bz/news/category/publisher-spanish/"><img class="alignnone wp-image-295660 size-medium" src="http://amandala.com.bz/news/wp-content/uploads/2017/02/From-the-Pub-Evan-X-SP.png" alt="" width="300" height="186" /></a></div>
		</div><div id="text-26" class="widget-container widget_text rightwidget">			<div class="textwidget"><a href="http://amandala.com.bz/news/category/spanish-editorial/"><img class="alignnone wp-image-295660 size-medium" src="http://amandala.com.bz/news/wp-content/uploads/2017/02/Amandala-Editorial-Espanol-2017.png" alt="" width="300" height="186" /></a></div>
		</div><div id="text-55" class="widget-container widget_text rightwidget">			<div class="textwidget"><img class="alignleft size-full wp-image-297700" src="http://amandala.com.bz/news/wp-content/uploads/2017/05/Share-News-Tips-3.png" alt="" width="300" height="576" /></div>
		</div>
<div style="width:315px; float:left; ">

<div style="float:left; width:148px; ">


</div>

<div style="float:left; width:148px; margin-left:18px;">


</div>

</div>

</div><!-- #right closer -->
</div><!-- #content_holder closer -->

</div>

</div><!-- #content closer -->

</div>

<div id="footer_widget" >

<div class="inside">

<!-- WIDGET SPACE -->





<div class="logo">

<a href="#top" class="toparrow"><img src="http://amandala.com.bz/news/wp-content/themes/LondonLiveOld/images/top_arrow.png" class="top" /></a>


</div>

<!-- WIDGET END -->

</div><!-- #inside -->

</div><!-- #footer_widget closer -->

<div id="footer">

<div class="inside">

<div class="left">&copy; 2018 Amandala Newspaper. All Rights Reserved.</div><!-- #left -->

<div class="right"></div><!-- #right -->

</div><!-- #inside -->

</div><!-- #footer -->

</div><!-- #container closer -->

<div id="su-footer-links" style="text-align: center;"></div><script type='text/javascript' src='http://amandala.com.bz/news/wp-content/plugins/wp-marquee/javascript/jquery.marquee.min.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/plugins/wp-marquee/javascript/iniMarquee.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/amandala.com.bz\/news\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/amandala.com.bz\/news\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/amandala.com.bz\/news\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","sending":"Sending ..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=3.9.1'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-content/plugins/wp-carousel-free/inc/owl-carousel/owl.carousel.min.js?ver=1'></script>
<script type='text/javascript' src='http://amandala.com.bz/news/wp-includes/js/wp-embed.min.js?ver=e8b0be65958c3af06b639aff2a75fea2'></script>
<div id="fb-root"></div>
<script type="text/javascript">
  window.fbAsyncInit = function() {
    FB.init({"appId":"199286080135440","channelUrl":"http:\/\/amandala.com.bz\/news\/?sfc-channel-file=1","status":true,"cookie":true,"xfbml":true,"oauth":true});
      };
  (function(d){
       var js, id = 'facebook-jssdk'; if (d.getElementById(id)) {return;}
       js = d.createElement('script'); js.id = id; js.async = true;
       js.src = "//connect.facebook.net/en_US/all.js";
       d.getElementsByTagName('head')[0].appendChild(js);
   }(document));     
</script>

<script type="text/javascript">var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));</script> <script type="text/javascript">var pageTracker = _gat._getTracker("UA-5579601-1");pageTracker._trackPageview();</script>
</body>

</html>